PAT 1011 World Cup Betting

原题链接:PAT 1011 World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W , T and L.

Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

题目大意:

足球比赛有3场,然后题目给出了每一场瀛、平、输的赔率,并给出了最后获得钱的公式。
要求返回理论上能获得的最大收益。

方法一:模拟

思路:

找出每场比赛赔率最大的进行下注,然后按照公式按照题目的要求输出即可
(odds应该是赔率)

C++ 代码:

#include <iostream>
using namespace std;

double res = 1.0;

int main(){
	int t = 3;
	
	// 三场比赛 
	for(int i = 0; i < 3; i++ ){
		double a, b, c, max;
		scanf("%lf %lf %lf", &a, &b, &c);
		
		max = a;
		if(b > max) max = b;
		if(c > max) max = c;
		
		res *= max;
		if(max == a) 
			printf("W ");
		else if(max == b)
			printf("T ");
		else
			printf("L ");
	}
	
	printf("%.2lf", (res * 0.65 - 1) * 2);
	
	return 0; 
}

复杂度分析:

  • 时间复杂度:O(1),问题的规模是固定的,三场比赛
  • 空间复杂度:O(1)
  • 7
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值