PAT 1157 Anniversary

原题链接:PAT 1157 Anniversary(25分)
关键词:string 、最值
参考的浒鱼鱼的博客:19年春季第二题 PAT甲级 1157 Anniversary(25 分)

Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID’s of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.

Input Specification:

Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤10​5​​). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID’s are distinct.

The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (≤10​5​​). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID’s are distinct.

Output Specification:

First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus – notice that the 7th - 14th digits of the ID gives one’s birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.

Sample Input:

5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042

Sample Output:

3
150702193604190912

题目大意: 找到来访的校友中年级最大的那一个。
代码:

// pat 1157
#include <iostream>
#include <string>
#include <set> 
using namespace std;

const int maxn = 1e5 + 10;
int n, m;	//校友数 参加的人数 
set<string> se;

int main(){
	cin >> n;
	getchar();
	for(int i = 0; i < n; i ++ ){
		string s1;
		getline(cin, s1);
		se.insert(s1);
	}
	
	int cnt = 0;	//记录来客中校友的数目 
	string ans, old = "20200704";
	cin >> m;
	getchar();
	for(int i = 1; i <= m; i ++ ){
		string s2;
		getline(cin, s2);
		if(se.find(s2) != se.end()) cnt ++;	
		if(cnt != 0){
			if(se.find(s2) != se.end() && s2.substr(6, 8) < old){	//有校友,输出校友中年纪最大的 
				old = s2.substr(6, 8);
				ans = s2;
			}
		}
		else{
			if(s2.substr(6, 8) < old){	//没有校友就输出来宾中年纪最大的 
				old = s2.substr(6, 8);
				ans = s2;
			}
		}

	}
	cout << cnt << endl;
	cout << ans;
	
	return 0;
} 

注意:

  • set容器的find()方法要是没找到返回值是end()的值而不是-1;
  • getline()默认以换行为结束,在读完n或者m后需要用getline()读入时,需要用getchar()吃掉换行符(\n),否则getline()读到\n就结束,读进去的是空字符串;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值