PAT 1120 Friend Numbers

原题链接:1120 Friend Numbers (20分)

Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID’s among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

题目大意:

给出一组数, 要求返回这些数中各位数之和。要求去重以及从小到大排序。

思路:

set存各位数之和可以自动去重、排序。
还有就是PAT的输出格式,最后不能有空格。

C++ 代码:

// pat_a_1120 
#include <iostream>
#include <set>
using namespace std;

const int maxn = 1010;

int n, t;
int a[maxn];
set<int> st;

// 求各位数之和 
int getsum(int x){
	int sum = 0;
	while(x != 0){
		sum += x % 10;
		x /= 10;
	}
	return sum;
}

int main(){
	cin >> n;
	for(int i = 1; i <= n; i++ ){
		cin >> t;
		st.insert(getsum(t));
	}

	// 输出 
	cout <<  st.size() << endl;
	for(auto it = st.begin(); it != st.end(); it++ ){
		if(it == st.begin()) cout << *it;
		else
			cout << " " << *it;
	}		
	 
	return 0;
}

复杂度分析:

  • 时间复杂度:O(n),需要遍历一遍求各位数之和,插入O(1),最后输出不超过O(n)
  • 空间复杂度:O(1),不需要存到数组中
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值