PAT 1118 Birds in Forest

原题链接:1118 Birds in Forest (25分)
关键词:并查集

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​ ) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1 B​2… B​k
​​

where K is the number of birds in this picture, and B​i​​ 's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104​​ .
After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

题目大意: 摄影师拍了一些树上的鸟的照片,其中在一张照片上的可以认为在一棵树上,问你有几棵树、几只鸟,以及给出两个鸟问你是否在一棵树上。

分析: 考察并查集基本用法 ,其中在同一棵树上的鸟可以合并为一个集合,最终有几个集合就是有几棵树。

  1. 有多少只鸟:因为鸟是从1开始编号的,输入鸟的编号最大的那一个就是鸟的总数;
  2. 有多少棵树:将所有在一棵树上的鸟合并为一个集合,最终有几个集合就有多少棵树:遍历father数组,满足father[i] == i的数目就是集合数;
  3. 判断两只鸟是否在一棵树上:对比findfather[a]findfather[b]即可;

代码:

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;
const int N = 10010;

int father[N];

void init() {   //初始化
    for (int i = 1; i < N; i++) {
        father[i] = i;
    }
}

int findfather(int x) { //高级写法
    return father[x] == x ? x : father[x] = findfather(father[x]);
}

int n, m;   //n照片数

vector<int> v[N];   //二维数组放n张照片中的鸟
int maxNum = -1;

int main()
{
    cin >> n;
    init();
    for (int i = 0; i < n; i++) {   //输入
        int num = 0;
        cin >> num; //照片中鸟的数量
        for (int j = 0; j < num; j++) {
            int t;
            cin >> t;
            maxNum = max(t, maxNum);    //最大编号就是鸟的数目
            v[i].push_back(t);
        }
        for (int j = 0; j < v[i].size() - 1; j++) { //把同一个照片里的鸟合并集合
            int a = v[i][j]; int b = v[i][j + 1];
            a = findfather(a); b = findfather(b);
            if (a != b) {
                father[a] = b;
            }
        }
    }

    int ans = 0;    //树的数量就是并查集里的种类数量
    for(int i = 1; i <= maxNum; i ++ ){
        if(father[i] == i) ans++;
    }
    
    cout << ans << " "<< maxNum << endl;

    cin >> m;   //m个询问
    for (int i = 0; i < m; i++){
        int a, b;
        cin >> a >> b;

        if (findfather(a) == findfather(b)) {
            cout << "Yes" << endl;
        }
        else {
            cout << "No" << endl;
        }
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值