PAT 1106 Lowest Price in Supply Chain (25分)

原题链接:1106 Lowest Price in Supply Chain (25分)
关键词:DFS、树的遍历

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105​​ ), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i ID[1] ID[2] … ID[K​i ]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K​j being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10​10​​ .

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2

题目大意: 给出你供销链中的成员,原始价格和每经过一人多上涨的利率,问你最后到达零售商的最便宜的价格以及给出最便宜的价格的零售商数。

分析: 原始供货商相当于树的根,零售商相当于树的叶子结点。因此本题的任务就是找到树中的具有最小深度的叶子结点的深度和个数。

代码:

#include <cstdio>
#include <vector>
#include <cmath>
using namespace std;

const int maxn = 1e5 + 10, INF = 0X3f3f3f;
vector<int> v[maxn];
int mindepth = INF, minnum = 1;

void dfs(int index, int depth) {
    if(mindepth < depth) return ;
    if(v[index].size() == 0) {  //是零售商
        if(mindepth == depth)
            minnum++;
        else if(mindepth > depth) { //找到更小的深度,更新
            mindepth = depth;
            minnum = 1;
        }
    }
    for(int i = 0; i < v[index].size(); i++)
        dfs(v[index][i], depth + 1);
}

int main(){
    int n;	//成员数
    double p, r;	//原始价格 利率
    scanf("%d %lf %lf", &n, &p, &r);
    for(int i = 0; i < n; i++) {
        int k;
        scanf("%d", &k);
        for(int j = 0; j < k; j++) {
            int c;
            scanf("%d", &c);
            v[i].push_back(c);
        }
    }
    
    dfs(0, 0);
    printf("%.4f %d", p * pow(1 + r/100, mindepth), minnum);
    return 0;
} 

遇到的库函数:
pow():
需要引用<cmath>头文件

area = pow(4.02)	//Area = 4的2次方
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值