PAT 1107 Social Clusters (30分)

原题链接:1107 Social Clusters (30分)
关键词:并查集

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki : hi[1] hi​​ [2] … hi​​ [Ki]

where Ki (>0) is the number of hobbies, and hi [j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

题目大意: 有n个人,每个人有k个爱好,如果两个人有任意一个爱好相同,就称为他们处于同一个社交网络。求这n个人一共形成了多少个社交网络。

分析:

  1. 首先,并查集要写好findfather、合并、初始化;
  2. course[t]表示任意一个喜欢t活动的人的编号。如果当前的课程t,之前并没有人喜欢过,那么就course[t] = i,i为它自己的编号,表示i为喜欢course[t]的第一个人的编号
  3. course[t]是喜欢t活动的人的编号,那么findFather(course[t])就是喜欢这个活动的人所处的社交圈子的根结点,合并根结点和当前人的编号的结点i。即Union(i, findFather(course[t])),把它们处在同一个社交圈子里面;
  4. isRoot[i]表示编号i的人是不是他自己社交圈子的根结点,如果等于0表示不是根结点,如果不等于0,每次标记isRoot[findFather(i)]++,那么isRoot保存的就是以他为根节点的社交圈里面的总人数;
  5. isRoot中不为0的编号的个数cnt就是社交圈圈子的个数,对isRoot进行排序后输出前cnt个就是题目要的答案;

代码:

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

const int maxn = 1010; 
vector<int> father, isRoot;	//isroot 为0说明不是他圈子里的根结点,不为0则是圈子中热人数 
int n, k, t, cnt = 0;
int course[maxn] = {0};	//把兴趣相同的人放到一个数组 

int cmp1(int a, int b){
    return a > b;
}
int findFather(int x) {
	return x == father[x] ? x : father[x] = findFather(father[x]);
}

void Union(int a, int b) {	//合并 
    int faA = findFather(a);
    int faB = findFather(b);
    if(faA != faB)
        father[faA] = faB;
}
int main() {
    scanf("%d", &n);
    father.resize(n + 1);
    isRoot.resize(n + 1);
    
    for(int i = 1; i <= n; i++) father[i] = i;	//初始化 
        
    for(int i = 1; i <= n; i++) {
        scanf("%d:", &k);
        for(int j = 0; j < k; j++) {
            scanf("%d", &t);
            if(course[t] == 0)	//之前没人喜欢过就把他设置为根结点 
                course[t] = i;
            Union(i, findFather(course[t]));
        }
    }
    
    for(int i = 1; i <= n; i++)
        isRoot[findFather(i)] += 1;
        
    for(int i = 1; i <= n; i++) {	//找根结点的数目 
        if(isRoot[i] != 0)
            cnt++;
    }
    
    //输出 
    printf("%d\n", cnt);
    sort(isRoot.begin(), isRoot.end(), cmp1);
    for(int i = 0; i < cnt; i++) {
        printf("%d", isRoot[i]);
        if(i != cnt - 1) printf(" ");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值