poj-3273 Monthly Expense

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7707 Accepted: 3180

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500
 
题目大意:知道农民接下来N天每天花的钱,不改变顺序要分成M份。求最大一份的最小值是多少。
二分查找,代码:
 
 
 
 
 
 
#include<iostream>  
using namespace std;  
int i,j,n,m,cxb[100010];  
bool fine(int a)  
{  
    int temp=0,x=1;  
    for(i=1;i<=n;i++)  
    {  
        if(x>m)  
            return false;  
        temp+=cxb[i];  
        if(temp>a)  
        {  
            temp=cxb[i];  
            x++;  
        }  
    }  
    if(x<=m)  
        return true;  
}  
int main()  
{  
    while(scanf("%d%d",&n,&m)!=EOF)  
    {  
        int sum=0,min=0,max,mid;  
        for(i=1;i<=n;i++)  
        {  
            scanf("%d",&cxb[i]);  
            sum+=cxb[i];  
            if(cxb[i]>min)  
                min=cxb[i]; //最小为花的最多的那天 
        }  
        max=sum;//最大为总的钱数 
        int ans; 
        while(max>=min)//进行二分查找  
        {  
            mid=(max+min)/2;  
            if(fine(mid))  
            {  
                max=mid-1;  
                ans=mid;  
            }  
            else  
            {  
                min=mid+1;  
            }  
        }  
        printf("%d\n",ans);  
    }  
    return 0;  
} 





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值