2488_A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18356 Accepted: 6181

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
题目给出格子的长和宽,要求以马的走法能否走完全部格子,还要按字典序( lexicographically)输出!
模拟马的走法(int step[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};)
以下是代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#define max 27
int map[max][max],x[max],y[max];
int p,q,t=0,sign;
int step[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};//模拟马走的步子 
void cxbdfs(int a,int b)// 深搜
{
	int x1,y1,i;
	if(sign)// 标记退出 
		return;
	t++;
	x[t]=a;
	y[t]=b;
	if(t==p*q) // 当全部走遍,标记 
	{
		sign=1;
		return;
	}
	map[a][b]=1;
	for(i=0;i<8;i++)
	{
		x1=a+step[i][0];
		y1=b+step[i][1];
		if(x1>0 && y1>0 && x1<=q && y1<=p && map[x1][y1]==0)// 符合条件进入搜索 
		{
			cxbdfs(x1,y1);
			t--;
		}
	}
	map[a][b]=0;//不符合条件回溯时地图从新标记 
}
int main()
{
	int i,n,j=0;
	scanf("%d",&n);
	memset(map,0,sizeof(map));
	while(n--)
	{
		j++;		
		sign=0;
		scanf("%d%d",&p,&q);
		cxbdfs(1,1);
		printf("Scenario #%d:\n",j);
		if(sign)
		{
			for(i=1;i<=p*q;i++)
				printf("%c%d",x[i]+'A'-1,y[i]);
			printf("\n");
		}
		else
			printf("impossible\n");
		printf("%s",n==0?"":"\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值