poj-3349 Snowflake Snow Snowflakes

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 20831 Accepted: 5445

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.
 
 
 
#include<iostream>
#include<vector>
using namespace std;
const int N=9997;
int i,j,k,snownum;
struct set
{
	int num[6],sum;
};
vector<set> hash[N];
bool contrast(set a,set b)
{
	for(int i=0;i<6;i++)
	{
		if(a.num[0]==b.num[i%6] && a.num[1]==b.num[(i+1)%6] && a.num[2]==b.num[(i+2)%6] && a.num[3]==b.num[(i+3)%6] && a.num[4]==b.num[(i+4)%6] && a.num[5]==b.num[(i+5)%6])
			return true;
		if(a.num[5]==b.num[i%6] && a.num[4]==b.num[(i+1)%6] && a.num[3]==b.num[(i+2)%6] && a.num[2]==b.num[(i+3)%6] && a.num[1]==b.num[(i+4)%6] && a.num[0]==b.num[(i+5)%6])
			return true;
	}
	return false;
}
bool search()
{
	for(i=0;i<N;i++)
	{
		for(j=0;j<hash[i].size();j++)
			for(k=j+1;k<hash[i].size();k++)
			{
				if(hash[i][j].sum==hash[i][k].sum  && contrast(hash[i][j],hash[i][k]))
					return true;
			}
	}
	return false;
}
int main()
{
	set temp;
	scanf("%d",&snownum);
	for(i=1;i<=snownum;i++)
	{
		temp.sum=0;
		for(j=0;j<6;j++)
		{
			scanf("%d",&temp.num[j]);
			temp.sum+=temp.num[j];
		}
		hash[temp.sum%N].push_back(temp);
	}
	puts(search()?"Twin snowflakes found.":"No two snowflakes are alike.");
	return 0;
}


基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip基于bert实现关系三元组抽取python源码+数据集+项目说明.zip 个人大四的毕业设计、课程设计、作业、经导师指导并认可通过的高分设计项目,评审平均分达96.5分。主要针对计算机相关专业的正在做毕设的学生和需要项目实战练习的学习者,也可作为课程设计、期末大作业。 [资源说明] 不懂运行,下载完可以私聊问,可远程教学 该资源内项目源码是个人的毕设或者课设、作业,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96.5分,放心下载使用! 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),供学习参考。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值