NEFU 696 Dart game 背包dp

Dart game

Time Limit 1000ms

Memory Limit 65536K

description

   Darts originated in Australia. Australia's aborigines initially for hunting and hit the enemy's weapon. 
   A game of darts in which the players attempt to score points by throwing the darts at a target.
Figure:DART BOARD
   Darts movement rules of the game is very simple, the target is 1-20 points and the central circle is 50 small zoning, edge is 25 division, the rough circle line of fan-shaped covered area is 1-20 points and three times the corresponding division. This game is generally played by two people but can be played by teams. Each player starts with N points. The goal for each player is to reach zero by subtracting the amount they score from the amount they had left,but final throwing must be double division. And the first to reduce his/her score to zero wins.
   So the task is : 
   Given a dart scores N that a player starts with, you are required to calculate how many different ways to reach zero. One is different way to another means at least one dart hits different division.Ways which have different orders and same divisions are the same way. For example,if N=4,there are 4 different ways reach to zero:the first is double 2,the second is 2 and double 1, the third is twice of double 1,the fourth is twice of 1 and double 1 .
   The answer may be very large,you have to module it by 2011. 
							

input

The input contains several test cases.
   Each test case contains an integer N ( 0 < N ≤ 1001 ) in a line.
   N=0 means end of input and need not to process.
							

output

For each test case, output how many different ways to reach zero.
							

sample_input

5
4
3
2
1
0
							

sample_output

6
4
1
1
0
							
-----------------------------------

至少含有一种double的取法数=总的取法-不含有double的取法。

多水的题啊!!!!数据有误!!!有误!!啊!发火

---------------------------------

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int a[111]= {1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,25,     //21
            3,6,9,12,15,18,21,24,27,30,33,36,39,42,45,48,51,54,57,60,   //41
            2,4,6,8,10,12,14,16,18,20,22,24,26,28,30,32,34,36,38,40,50};//62
int f[1111];
int g[1111];
int n;

int main()
{
    memset(f,0,sizeof(f));
    memset(g,0,sizeof(g));

    f[0]=1;
    for (int i=0; i<62; i++)
    {
        for (int j=0; j<=1001-a[i]; j++)
        {
            if (f[j])
            {
                f[j+a[i]]=(f[j+a[i]]+f[j])%2011;
            }
        }
    }
    //for (int i=0;i<100;i++) printf("%d ",f[i]);
    g[0]=1;
    for (int i=0; i<41; i++)
    {
        for (int j=0; j<=1001-a[i]; j++)
        {
            if (g[j])
            {
                g[j+a[i]]=(g[j+a[i]]+g[j])%2011;
            }
        }
    }

    while (~scanf("%d",&n))
    {
        if (n==0) break;
        printf("%d\n",(f[n]-g[n]+2011)%2011);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值