NEFU 697 Similar Word KMP

Similar Word

Time Limit 1000ms

Memory Limit 65536K

description

  It was a crummy day for Lur. He failed to pass to the CET-6 (College English Test Band-6). Looking back on how it was in last year gone by, he gradually noticed he had fled too many English Lessons. But he determines to memorize words on his bed ,not in the classroom. You know, it is not that easy to pass the test mainly because the large amount of born words. 
     Lur is intelligent on games , never English. He cann't learn the similar words by heart. He 
always choose to select a word to learn from the similar words . For him, two words are similar if and only if one word can equal to the other by multiple cyclic shift(at least 1). For example, "car" and "arc" are similar words, while "car" and "rca" are also similar words . To save more time to play games, 
  Lur want to know wether two words are similar words faster, he asks you to write a program to tell him ,can you help him ? 
							

input

  There are multiple test cases. Each case contains two lines. Each line contains a word, 
W. You can assume that length(W)<=10^5 . Ended by EOF.
							

output

  Output “yes” in a single line if two words are similar,otherwise you should output  “no” in a single line.
							

sample_input

car
arc
car
cra
car
car
							

sample_output

yes
no
no
							

-------------

KMP

但是!!直接暴力也能过!!!魂淡!!!!

------------

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

char T[1111111];
char P[1111111];
int  f[1111111];


bool find()
{
    int n=strlen(T),m=strlen(P);
    f[0]=0;
    f[1]=0;
    for (int i=1; i<m; i++)
    {
        int j=f[i];
        while (j && P[i]!=P[j]) j=f[j];
        f[i+1]=(P[i]==P[j])?(j+1):(0);
    }

    int j=0;
    for (int i=0; i<n; i++)
    {
        while (j && P[j]!=T[i]) j=f[j];
        if (P[j]==T[i]) j++;
        if (j==m) return true;
    }
    return false;
}

int main()
{
    while (~scanf("%s%s",T,P))
    {
        memset(f,0,sizeof(f));
        int lenT=strlen(T);
        int lenP=strlen(P);
        if (lenT!=lenP)
        {
            printf("no\n");
        }
        else if (strcmp(P,T)==0)
        {
            printf("no\n");
        }
        else
        {
            for (int i=lenT; i<lenT*2; i++)
            {
                T[i]=T[i-lenT];
            }
            T[lenT*2]='\0';
            if (find())
            {
                printf("yes\n");
            }
            else
            {
                printf("no\n");
            }
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值