Similar Word

 

Similar Word

TimeLimit: 1 Second  MemoryLimit: 32Megabyte

Totalsubmit: 45  Accepted: 11 

Description

It was a crummy day for Lur. He failed to pass to the CET-6(College English Test Band-6). Looking back on how it was in lastyear gone by, he gradually noticed he had fled too many EnglishLessons. But he determines to memorize words on his bed ,not in theclassroom. You know, it is not that easy to pass the test mainlybecause the large amount of born words. 
    Lur is intelligent on games ,never English. He cann't learn the similar words by heart.He 
always choose to select a word to learn from the similar words .For him, two words are similar if and only if one word can equal tothe other by multiple cyclic shift(at least 1). For example, "car"and "arc" are similar words, while "car" and "rca" are also similarwords . To save more time to playgames, 
Lur want to know wether two words are similar words faster, he asksyou to write a program to tell him ,can you help him? 

Input

There are multiple test cases. Each case contains two lines. Eachline contains a word, 
W. You can assume that length(W)<= 10^5  .Ended by EOF.

Output

Output “yes” in a single line if two words are similar,otherwiseyou should output   “no” in a singleline.

Sample Input

car
arc
car
cra
car
car

Sample Output

yes
no
no

#include<string.h>
#include <string>
#include<algorithm>
#include<iostream>
#include <math.h>
#include <stdio.h>
#define MAX 100001
using namespace std;
char w[MAX*2],cw[MAX];
void getNext(char *p,int *next){
    int j,k,len=strlen(p);
    next[0]=-1;
    j=0;
    k=-1;
    while(j<len-1){
       if(k==-1||p[j]==p[k])   {
           j++;
           k++;
          next[j]=k;
       }
       else                
          k=next[k];
    }
}
int kmp(char *s,char *p){
    int next[MAX];
    int i,j,len=strlen(s);
    i=1;
    j=0;
    getNext(p,next);
    int len_p = strlen(p);
    while(i<2*len-1){
       if(j==-1||s[i%len]==p[j]){
           i++;
           j++;
       }
       else{
           j=next[j];     
       }
          if(j==len_p)
          return 1;
    }
    return 0;
}
int main(){
    int len;
    while(~scanf("%s%s",w,cw)){
       len=strlen(w);
       if(len!=strlen(cw))
          printf("no\n");
       else{
          if(kmp(w,cw))
              printf("yes\n");
          else
              printf("no\n");
       }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值