1037

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M )whereanegativevaluecorrespondstoabonusproduct.Youcanapplycoupon3(withNbeing4)toproduct1(withvalueM 7) to get M 28back;coupon2toproduct2togetM 12 back; and coupon 4 to product 4 to get M 3back.Ontheotherhand,ifyouapplycoupon3toproduct4,youwillhavetopayM 12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

#include <iostream>
#include <algorithm>

using namespace std;

bool cmp(int a, int b)
{
    return a>b;
}

int coupon[100005];
int product[100005];

int main()
{
    int nc,np,total=0;
    scanf("%d", &nc);
    for(int i=0;i<nc;i++)
        cin >> coupon[i];
    scanf("%d", &np);
    for(int i=0;i<np;i++)
        cin >> product[i];

    sort(coupon,coupon+nc,cmp);
    sort(product,product+np,cmp);

    int i=0,j=0;
    while(coupon[i]>0 && product[j]>0 && i<nc && j<np)
    {
        total += coupon[i] * product[j];
        i++;
        j++;
    }
    int index1 = nc-1;
    int index2 = np-1;
    while(coupon[index1]<0 && product[index2]<0 &&index1>=0 && index2>=0)
    {
        total += coupon[index1] * product[index2];
        index1--;
        index2--;
    }
    cout << total;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值