【PAT (Advanced Level)】1058. A+B in Hogwarts (20)

1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

言简意赅,不多说;

代码:

/************************************
This is a test program for anything
Enjoy IT!
************************************/

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <set>
#include <fstream>
#include <string>
#include <cmath>
using namespace std;

int main()
{
	/*ifstream cin;
	cin.open("in.txt");
	ofstream cout;
	cout.open("out.txt");*/
	//
	// TO DO Whatever You WANT!
	string s1, s2;
	while (cin >> s1 >> s2)
	{
		int a[3] = { 0 }, b[3] = { 0 }, c[3] = { 0 };
		int j = 0;
		for (int i = 0; i < s1.length(); i++)
		{
			if (s1[i] == '.')
			{
				j++;
				continue;
			}
			a[j] = a[j] * 10 + s1[i] - '0';
		}
		j = 0;
		for (int i = 0; i < s2.length(); i++)
		{
			if (s2[i] == '.')
			{
				j++;
				continue;
			}
			b[j] = b[j] * 10 + s2[i] - '0';
		}
		int t;
		c[2] = (a[2] + b[2]) % 29;
		t = (a[2] + b[2]) / 29;
		c[1] = (a[1] + b[1] + t) % 17;
		t = (a[1] + b[1] + t) / 17;
		c[0] = (a[0] + b[0] + t);
		cout << c[0] << "." << c[1] << "." << c[2] << endl;
	}
	//
	// system("pause");
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值