A+B in Hogwarts

Description

If you are a fan of Harry Potter, you would know the school he is attending to, the Hogwarts School for Witchcraft and Wizardry. What you might not know is that Harry is never good at math, yet he doesn't want to bother Hermione for trivial A+B problems. Now your job is to write a simple calculator for him -- the calculator is so simple that it handles non-negative integer additions only.

What is not so simple is that the world of Witchcraft and Wizardry dosen't use a fixed radix numeration system. That is, an integer is represented with different radices for different digits -- the radix for the i-th digit is the i-th prime number. For example, the decimal number 2 is 10 in Hogwarts (let's denote it by 210 = 1,0H) since the radix for the 1st digit is the 1st prime number 2. Similarly we have 610 = 1,0,0H since the radix for the 2nd digit is 3.

Input

The input consists of multiple test cases, each occupies a line with two integers in Hogwarts' system. Digits of a Hogwarts' integer are seperated by ',' and the two numbers are seperated by a space. Each number has at most 25 digits.

Output

For each test case, print in one line the sum of the two given numbers in Hogwarts' system.

Sample Input

1,0 2,1
4,2,0 1,2,0
1 10,6,4,2,1

Sample Output

1,0,1
1,1,1,0
1,0,0,0,0,0

这道题题意理解就容易做了,题意说的是第i为以第i个素数为基数,
6 = 100 = 1*2*3+0*2+0
所以这道题只需要按大数的方式处理,进位就可以了。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
const int maxn = 35, N = 10005;
int prime[maxn], vis[N], a[maxn], b[maxn], ans[maxn];
char str[N], ch[N];
/*
第i位就是第i个素数
例如
100 = 0+0*2+1*2*3 = 6
*/
void praseInput ( char str[], int a[] )
{
    char * pos;
    int cnt = 0;
    while ( pos = strrchr ( str, ',' ) )
    //如果成功,则返回指定字符最后一次出现位置的地址,如果失败,则返回 false
    {
        * pos = '\0';
        a[cnt ++] = atoi ( pos+1 ); //从pos+1开始转换数字
    }
    a[cnt ++] = atoi ( str );
}
void add ( )
{
    for ( int i = 0; i < maxn-1; i ++ )
    {
        ans[i] = ans[i]+a[i]+b[i];  //需要加上本身
        ans[i+1] = ans[i]/prime[i];
        ans[i] = ans[i]%prime[i];
    }
}
void print ( )
{
    int i;
    for ( i = maxn-1; i >= 0 && ans[i] == 0; i -- )
            ;   //从后往前打印,去掉0
    while ( i > 0 )
    {
        printf ( "%d,", ans[i] );
        i --;
    }
    printf ( "%d\n", ans[0] );
}
void test_print ( int a[] )
{
    for ( int i = 0; i < maxn; i ++ )
        printf ( "%d ", a[i] );
    printf ( "\n" );
}
int main ( )
{
    int cnt = 0;
    vis[0] = vis[1] = 1;
    for ( int i = 2; i < N; i ++ )  //求出素数
    {
        if ( ! vis[i] )
            prime[cnt ++] = i;
        for ( int j = 0; j < cnt && i*prime[j] < N; j ++ )
        {
            vis[ i*prime[j] ] = 1;
            if ( i%prime[j] == 0 )
                break ;
        }
        if ( cnt > maxn )
            break ;
    }
    while ( ~ scanf ( "%s%s", str, ch ) )
    {
        memset ( a, 0, sizeof ( a ) );
        memset ( b, 0, sizeof ( b ) );
        memset ( ans, 0, sizeof ( ans ) );
        praseInput ( str, a );
        praseInput ( ch, b );
        add ( );
        print ( );
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,以下是一个简单的 Page Object Model 的代码示例: ```python from selenium.webdriver.common.by import By from selenium.webdriver.support.ui import WebDriverWait from selenium.webdriver.support import expected_conditions as EC class WelcomePage: def __init__(self, driver): self.driver = driver def is_title_matches(self): """检查页面标题是否匹配""" return "PetClinic" in self.driver.title def get_started_button(self): """获取 Get started 按钮""" return WebDriverWait(self.driver, 10).until( EC.element_to_be_clickable((By.CSS_SELECTOR, 'a.btn-primary'))) def click_get_started(self): """点击 Get started 按钮""" get_started_button = self.get_started_button() get_started_button.click() class LoginPage: def __init__(self, driver): self.driver = driver def is_title_matches(self): """检查页面标题是否匹配""" return "PetClinic" in self.driver.title def get_username_field(self): """获取用户名输入框""" return self.driver.find_element_by_id("username") def get_password_field(self): """获取密码输入框""" return self.driver.find_element_by_id("password") def get_login_button(self): """获取登录按钮""" return self.driver.find_element_by_css_selector("button[type='submit']") def login(self, username, password): """登录""" username_field = self.get_username_field() password_field = self.get_password_field() login_button = self.get_login_button() username_field.clear() username_field.send_keys(username) password_field.clear() password_field.send_keys(password) login_button.click() ``` 在这个示例中,我们定义了两个 Page Object:WelcomePage 和 LoginPage。WelcomePage 用于描述欢迎页面,LoginPage 用于描述登录页面。每个 Page Object 都有自己的方法,用于访问和操作该页面的元素。这些方法封装了对元素的定位和操作,使测试代码更加清晰和易于维护。在测试代码中,我们只需要创建相应的 Page Object 实例,并调用其方法来访问和操作页面元素,而无需关心元素的具体定位方式和操作细节。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值