HDU5974 A Simple Math Problem(求根公式)

A Simple Math Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3691 Accepted Submission(s): 1156

Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions: X+Y=a Least Common Multiple (X, Y) =b

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*104),b(1≤b≤109),and their meanings are shown in the description.Contains most of the 12W test cases.

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).

Sample Input
6 8
798 10780

Sample Output
No Solution
308 490

题意

给你a,b,求满足X+Y=a,lcm(X,Y)=b,的X,Y

思路

设X,Y的最大公约数为t,即 g c d ( X , Y ) = t gcd(X,Y)=t gcd(X,Y)=t,那么有 X = k 1 t X=k_{1}t X=k1t, Y = k 2 t Y=k_{2}t Y=k2t,其中 k 1 , k 2 k_{1},k_{2} k1,k2互质, X + Y = ( k 1 + k 2 ) t X+Y=(k_{1}+k_{2})t X+Y=(k1+k2)t, l c m ( X , Y ) = X Y t = k 1 k 2 t lcm(X,Y)=\frac{XY}{t}=k_{1}k_{2}t lcm(X,Y)=tXY=k1k2t,又因为 k 1 + k 2 k_{1}+k_{2} k1+k2 k 1 k 2 k_{1}k_{2} k1k2互质,所以 g c d ( X + Y , l c m ( X , Y ) ) = t gcd(X+Y,lcm(X,Y))=t gcd(X+Y,lcm(X,Y))=t,又有 g c d ( X , Y ) = t gcd(X,Y)=t gcd(X,Y)=t,所以 g c d ( X , Y ) = g c d ( X + Y , l c m ( X , Y ) ) = g c d ( a , b ) = t gcd(X,Y)=gcd(X+Y,lcm(X,Y))=gcd(a,b)=t gcd(X,Y)=gcd(X+Y,lcm(X,Y))=gcd(a,b)=t
然后又 l c m ( X , Y ) = X Y t lcm(X,Y)=\frac{XY}{t} lcm(X,Y)=tXY, Y = a − X Y=a-X Y=aX
X 2 − a X + t b = 0 X^{2}-aX+tb=0 X2aX+tb=0,其中 t = g c d ( a , b ) t=gcd(a,b) t=gcd(a,b),用求根公式求解即可,X为较小一项,求完后再检验一下

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
using namespace std;
long long gcd(long long a,long long b)
{
    return b?gcd(b,a%b):a;
}
int main()
{
    long long a,b;
    while(scanf("%lld%lld",&a,&b)!=EOF)
    {
        int t=gcd(a,b);
        if(a*a-4*t*b<0)
            printf("No Solution\n");
        else
        {
            long long x=min((a+sqrt(a*a-4*t*b))/2,(a-sqrt(a*a-4*t*b))/2);
            long long y=a-x;
            if(x*y/t==b)
            printf("%lld %lld\n",x,y);
            else
                printf("No Solution\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值