python2.7的Numpy和Matplotlib即依赖库dateutil和pyparsing的安装

1.安装好python2.7;

2.下载安装setuptools,https://pypi.python.org/pypi/setuptools/#windows下载ez_setup.py这个文件,在cmd命令行执行:#python ez_setup.py

然后到pip的官网:https://pypi.python.org/pypi/pip下载对应我们python版本的pip,解压,然后在cmd进入到该目录中,执行:#python setup.py install

这时候就会自动安装pip到你python目录下的Scripts文件夹中。进入到Scripts目录下, 在里面我们可以看到pip.exe,然后我们进入到该文件夹中:

#cd C:\Python27\Scripts

#pip install dateutil(我在这里遇到点问题,提示没有需要的版本,所以进行了第3步,再回来执行第2步错误就解决了)

#pip install pyparsing

3.下载Numpy,SciPy,MatplotLib这三个库的exe,注意,这里用的是exe,因为MatplotLib的使用需要以Numpy的支持,所以最好先装NumPy再装MatplotLib。下载地址:

(虽然我的电脑是64位的,但是因为MatPlotLib没有找到64位版的,所以以上三个都是安装的32位的,可用)

完成以上后我运行了一个MatPlotLib的程序,报错:ImportError: No module named cycler

解决方法:回到Scripts目录下执行pip install cycler即可。


©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页