题目来源:http://poj.org/problem?id=1363
G: Rails
总时间限制: 1000ms 内存限制: 65536kB
描述
There is a famous railway station in PopPush City. Country thereis incredibly hilly. The station was built in last century. Unfortunately,funds were extremely limited that time. It was possible to establish only asurface track. Moreover, it turned out that the station could be only adead-end one (see picture) and due to lack of available space it could haveonly one track.
The local tradition is that every train arriving from the direction A continuesin the direction B with coaches reorganized in some way. Assume that the trainarriving from the direction A has N <= 1000 coaches numbered in increasingorder 1, 2, ..., N. The chief for train reorganizations must know whether it ispossible to marshal coaches continuing in the direction B so that their orderwill be a1, a2, ..., aN. Help him and write a program that decides whether itis possible to get the required order of coaches. You can assume that singlecoaches can be disconnected from the train before they enter the station andthat they can move themselves until they are on the track in the direction B.You can also suppose that at any time there can be located as many coaches asnecessary in the station. But once a coach has entered the station it cannotreturn to the track in the direction A and also once it has left the station inthe direction B it cannot return back to the station.
输入
The input consists of blocks of lines. Each block except thelast describes one train and possibly more requirements for its reorganization.In the first line of the block there is the integer N described above. In eachof the next lines of the block there is a permutation of 1, 2, ..., N. The lastline of the block contains just 0.
The last block consists of just one line containing 0.
输出
The output contains the lines corresponding to the lines withpermutations in the input. A line of the output contains Yes if it is possibleto marshal the coaches in the order required on the corresponding line of theinput. Otherwise it contains No. In addition, there is one empty line after thelines corresponding to one block of the input. There is no line in the outputcorresponding to the last ``null'' block of the input.
样例输入
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
样例输出
Yes
No
Yes
来源
Central Europe 1997
--------------------------------------------------------------
思路
这道题以前做过了,参见博文:POJ 1737 Rails(栈)
-----------------------------------------------------
代码
#include<iostream>
#include<fstream>
#include<vector>
using namespace std;
int n;
vector<int> a;
vector<int> sta;
vector<int> cont;
bool judge()
{
if (!sta.empty())
{
sta.clear();
}
if (!cont.empty())
{
cont.clear();
}
int i;
for (i=n-1; i>=0; i--)
{
while (!sta.empty() && sta.back() > a.at(i))
{
cont.push_back(sta.back());
sta.pop_back();
}
sta.push_back(a.at(i));
}
while (!sta.empty())
{
cont.push_back(sta.back());
sta.pop_back();
}
for (i=n-1; i>=0; i--)
{
if ((i+1)!=cont.at(n-1-i))
{
return false;
}
}
return true;
}
int main()
{
#ifndef ONLINE_JUDGE
ifstream fin("G.txt");
int i,tmp;
bool is_end = false;
while (fin >> n)
{
if (n==0)
{
break;
}
is_end = false;
while (!is_end)
{
a.clear();
for (i=0; i<n; i++)
{
fin >> tmp;
if (tmp==0)
{
is_end = true;
cout << endl;
break;
}
a.push_back(tmp);
}
if (!is_end)
{
if (judge())
{
cout << "Yes" << endl;
}
else
{
cout << "No" << endl;
}
}
}
}
fin.close();
#endif
#ifdef ONLINE_JUDGE
int i,tmp;
bool is_end = false;
while (cin >> n)
{
if (n==0)
{
break;
}
is_end = false;
while (!is_end)
{
a.clear();
for (i=0; i<n; i++)
{
cin >> tmp;
if (tmp==0)
{
is_end = true;
cout << endl;
break;
}
a.push_back(tmp);
}
if (!is_end)
{
if (judge())
{
cout << "Yes" << endl;
}
else
{
cout << "No" << endl;
}
}
}
}
#endif
}