5-2DUCCI序列 uva1594

1、问题描述:A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1, a2, … , an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:

( a1, a2, … , an) (| a1 - a2|,| a2 - a3|, … ,| an - a1|)

Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:

(8, 11, 2, 7) (3, 9, 5, 1) (6, 4, 4, 2) (2, 0, 2, 4) (2, 2, 2, 2) (0, 0, 0, 0).

The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:

(4, 2, 0, 2, 0) (2, 2, 2, 2, 4) ( 0, 0, 0, 2, 2) (0, 0, 2, 0, 2) (0, 2, 2, 2, 2) (2, 0, 0, 0, 2)

(2, 0, 0, 2, 0) (2, 0, 2, 2, 2) (2, 2, 0, 0, 0) (0, 2, 0, 0, 2) (2, 2, 0, 2, 2) (0, 2, 2, 0, 0)

(2, 0, 2, 0, 0) (2, 2, 2, 0, 2) (0, 0, 2, 2, 0) (0, 2, 0, 2, 0) (2, 2, 2, 2, 0) ( 0, 0, 0, 2, 2)

Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.

Input

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n(3 n 15), which represents the size of a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making a loop does not exceed 1,000.

Output

Your program is to write to standard output. Print exactly one line for each test case. Print LOOP' if the Ducci sequence falls into a periodic loop, printZERO’ if the Ducci sequence reaches to a zeros tuple.

The following shows sample input and output for four test cases.

Sample Input

4
4
8 11 2 7
5
4 2 0 2 0
7
0 0 0 0 0 0 0
6
1 2 3 1 2 3

Sample Output

ZERO
LOOP
ZERO
LOOP

2、并没有想到简便的方法,应用vector进行记录,并在生成新序列时进行比对,当比对不符时及时剪断是关键。

#include <iostream>
#include<cmath> 
#include<vector>
using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

#define maxn 1000+1
vector<int> l[maxn];

int judge(int c,int n){
    int sum=0;

    for(int i=0;i<c;i++){
            int flag=1;
        for(int j=0;j<n;j++){
            if(l[i][j]!=l[c][j]){
                flag=0;
                break;
            }
            else {
                sum+=l[c][j];
            }
        }
        if(flag==1){
        if(sum==0)return 1;
        else return 2;  
        }

    }
}


int main(int argc, char** argv) {
    int n;
    cin>>n;
    int m=0;
    for(int i=0;i<n;i++){
        int x;
        cin>>x;
        l[m].push_back(x);
    }
    int symbol=0;
    while(!symbol&&m<1000)
    {
    for(int i=0;i<n;i++){
        l[m+1].push_back(abs(l[m][i]-l[m][(i+1)%n]));
    }
    m+=1;
    symbol=judge(m,n);
}
if(symbol==1)cout<<"0循环"<<endl;
if(symbol==2)cout<<"有循环"<<endl;
if(symbol==0)cout<<"无循环"<<endl; 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值