2017浙江大学计算机和软件考研复试题C题 Infix Expression

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

Figure 1
Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:
8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1
Sample Output 1:
(a+b)*(c*(-d))
Sample Input 2:
8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1
Sample Output 2:
(a*2.35)+(-(str%871))

解题思路:

这道题相当于给出了树的邻接表,要求中序遍历输出公式,难点是什么时候该输出括号,什么时候不该输出括号。

递归函数应该这么想,从根节点开始执行:

f(节点){

判断节点是否为根节点和叶子节点,否则输出“(”

f(左子节点)

输出节点的数据(data)

f(右子节点)

判断节点是否为根节点和叶子节点,否则输出“)”
}


代码如下:

#include<iostream>
#include<string>
using namespace std;

int N;//节点个数
string* words;//存放每个节点的语句内容的数组
int**tree;//存放树的二维数组
int rootNo;//根节点序号(0开始计)

//找根节点的序号的函数
int findRootID() {
	int*No=new int[N];
	for (int i = 0; i < N; i++) No[i] = 1;
	for (int i = 0; i < N; i++) {
		if (tree[i][0] != -1) No[tree[i][0]-1] = 0;
		if(tree[i][1] != -1) No[tree[i][1]-1] = 0;
	}
	
	for (int i = 0; i < N; i++)
		if (No[i] == 1) return i;

	return -1;
}

//中序遍历并且输出
void inorderOut(int nodeNo) {
	if (!(tree[nodeNo][0] == -1 && tree[nodeNo][1] == -1) &&nodeNo!=rootNo) cout << "(";//如果该节点既不是根又不是叶子,输出一个左括号
	if (tree[nodeNo][0] != -1) inorderOut(tree[nodeNo][0]-1);
	cout << words[nodeNo];
	if (tree[nodeNo][1] != -1) inorderOut(tree[nodeNo][1]-1);
	if (!(tree[nodeNo][0] == -1 && tree[nodeNo][1] == -1) && nodeNo != rootNo) cout << ")";//如果该节点既不是根又不是叶子,输出一个右括号
}

int main() {
	cin >> N;
	
	words = new string[N];
	
	tree = new int*[N];
	for (int i = 0; i < N; i++) tree[i] = new int[2];
	for (int i = 0; i < N; i++) {
		cin >> words[i];
		cin >> tree[i][0];//输入的是第i个节点(从0开始计)的左子节点的序号
		cin >> tree[i][1];//输入的是第i个节点(从0开始计)的右子节点的序号
	}
        rootNo = findRootID();
	inorderOut(rootNo);
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值