甲级PATA1138 Postorder Traversal

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:
7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
Sample Output:
3


  题目的意思是说,给出一棵树的前序遍历和中序遍历,要求打印出后序遍历的第一个节点。

  这类型的题在PAT中考过多次了,通过两个遍历(其中一个为中序遍历)还原出一棵树的算法一定要熟练掌握,思路是从中序遍历中找到根节点的位置,然后划分出左子树和右子树,递归即可。须要注意的是,这道题只要求后序遍历的第一个节点,最多可输入50000个数据,千万不要先建树,再去中序遍历,否则会超时,得不到满分。应该想到,后续遍历的第一个节点,如果根有左子树,则一定在左子树上,往左子树递归即可。同理,如果根没有左子树但有右子树,那么往右子树递归。

  代码如下:

#include<cstdio>
using namespace std;

int N;
int preorder[50010];
int inorder[50010];

int getFirstNumber(int prel,int prer,int inl,int inr) {
	if (prel > prer) return - 1;
	if (prel == prer) return preorder[prel];
	int k;
	for (int i = inl; i <= inr; i++) {
		if (inorder[i] == preorder[prel]) {
			k = i;
			break;
		}
	}
	int leftnum = k - inl;//左子树的节点个数
	if (leftnum)
		return getFirstNumber(prel + 1, prel + leftnum,inl, k - 1);//往左子树递归
	else return getFirstNumber(prel + leftnum + 1, prer, k + 1, inr);//往右子树递归
}

int main() {
	scanf("%d", &N);
	for (int i = 0; i < N; ++i) {
		scanf("%d", &preorder[i]);
	}
	for (int i = 0; i < N; ++i) {
		scanf("%d", &inorder[i]);
	}
	printf("%d", getFirstNumber(0, N - 1, 0, N - 1));
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值