PAT B1048

1048. 数字加密(20)

本题要求实现一种数字加密方法。首先固定一个加密用正整数A,对任一正整数B,将其每1位数字与A的对应位置上的数字进行以下运算:对奇数位,对应位的数字相加后对13取余——这里用J代表10、Q代表11、K代表12;对偶数位,用B的数字减去A的数字,若结果为负数,则再加10。这里令个位为第1位。

输入格式:

输入在一行中依次给出A和B,均为不超过100位的正整数,其间以空格分隔。

输出格式:

在一行中输出加密后的结果。

输入样例:
1234567 368782971
输出样例:
3695Q8118
代码如下:

#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
char k[13] = {'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'J', 'Q', 'K'};
char s[110], s1[110], s2[110];
void _reverse(char * a){
    char ch;
    for(int i = 0, j =  strlen(a) - 1; i <= j; i++, j--){
        ch = a[i];
        a[i] = a[j];
        a[j] = ch;
    }
}
int main(){
    bool kkk = true;
    cin>>s>>s1;
    _reverse(s);
    _reverse(s1);
    int _max, temp;
    _max = max(strlen(s), strlen(s1));
    char ch;
    for(int i = 0; i < _max; i++){
        int nums = i < strlen(s) ? s[i] - '0' : 0;
        int nums1 = i < strlen(s1) ? s1[i] - '0' : 0;
        if((i % 2) == 0) {
            ch = k[(nums + nums1) % 13];
        }else{
            temp = nums1 - nums;
            if(temp < 0) temp += 10;
            ch = k[temp % 13];
        }
        s2[i] = ch;
    }
    for(int i = _max - 1; i >= 0; i--){
        cout<<s2[i];
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值