HDU 2054 E - A == B ?

传送门:E - A == B ?
 

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

 

Input

each test case contains two numbers A and B.

 

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

 

Sample Input

1 2 2 2 3 3 4 3

 

Sample Output

NO YES YES NO

 

分析:

题目很简单,比较两个数大小,开始注意到题目没有指明数据类型,可能有坑,考虑用字符数组做,但是交一发直接WA,后来发现没有处理后面0和小数点。

考虑几组测试数据(此题不用考虑001 和1的情况):

1.23 1.2300000

100 100.000000

 

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#define MANLEN 100000
using namespace std;

char a[MANLEN],b[MANLEN];

int main ()
{
    while(cin >> a >> b)
    {
        int len=0;
        if(strchr(a, '.')){
            for(len = strlen(a)-1; a[len] == '0'; len--);
            a[len+1] = '\0';
            if(a[len] == '.') a[len] = '\0';
        }
        if(strchr(b, '.')){
            for(len = strlen(b)-1; b[len] == '0'; len--);
            b[len+1] = '\0';
            if(b[len] == '.') b[len] = '\0';
        }
        //cout << a<< endl << b << endl;
        if(!strcmp(a, b))
            cout << "YES" << endl;
        else cout << "NO" << endl;
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值