A == B ?
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
Input
each test case contains two numbers A and B.
Output
for each case, if A is equal to B, you should print "YES", or print "NO".
Sample Input
1 2
2 2
3 3
4 3
Sample Output
NO
YES
YES
NO
import java.math.BigDecimal;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
BigDecimal a, b;
Scanner cin = new Scanner(System.in);
while (cin.hasNext()) {
a = cin.nextBigDecimal();
b = cin.nextBigDecimal();
if (a.compareTo(b) == 0) System.out.println("YES");
else System.out.println("NO");
}
}
}