openjudge avoid the lakes(简单dfs-最大联通量)

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

简单dfs

代码:

   


import java.util.Arrays;
import java.util.Scanner;
public class Main{
	static final int max=105;
	static int n,m,k;
	static boolean vis[][]=new boolean[max][max];
	static int ans=0;
	static int dirx[]={0,0,-1,1};
	static int diry[]={1,-1,0,0};
	public static void dfs(int x,int y){
		 for(int i=0;i<4;i++){
			 int xx=x+dirx[i];
			 int yy=y+diry[i];
			 if(xx<1||xx>n||yy<1||yy>m) continue;
			 if(!vis[xx][yy]) continue;
			 vis[xx][yy]=false;
			 ans++;
			 k--;
			 dfs(xx,yy);
		 }
	}
    public static void main(String[] args) {
	 Scanner scan=new Scanner(System.in);
	 n=scan.nextInt();
	 m=scan.nextInt();
	 k=scan.nextInt();
	 for(int i=0;i<max;i++){
		 Arrays.fill(vis[i], false);
	 }
	 for(int i=0;i<k;i++){
		 int a=scan.nextInt();
		 int b=scan.nextInt();
		 vis[a][b]=true;
	 }
	 int max=0;
	 for(int i=1;i<=n;i++)
		 for(int j=1;j<=m;j++){
			 if(vis[i][j]){
				 vis[i][j]=false;
				 k--;
				 ans=1;
				 dfs(i,j);
				 max=Math.max(max, ans);
			 }
             if(k==0) break;
		 }
	 System.out.println(max);
    }
    
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

OUC_lkc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值