Longest Ordered Subsequence(最长上升子序列及路径--模板题)

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence ( ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

动态规划求解:

    dp[i]表示以arr[i]为结尾的最长递增子序列的长度

    如果dp[i]>dp[j]&&0<=j<i,那么dp[i]=max(dp[0],dp[1],.....dp[i-1])+1

    我一开始的误解:dp[n-1]就是最长递增子序列的长度,当然不是,它只表示以arr[i]结尾的长度,最长递增子序列不一定以arr[i]结尾

时间复杂度:n^2   状态表示*状态计算

代码:

import java.util.Arrays;
import java.util.Scanner;
 
public class Main {
	static int dp[]=new int[1005];
	static int arr[]=new int[1005];
     public static void main(String[] args) {
		 Scanner scan=new Scanner(System.in);
		 int n=scan.nextInt();
		 Arrays.fill(dp, 1);
		 for(int i=0;i<n;i++)
			 arr[i]=scan.nextInt();
		 for(int i=0;i<n;i++)
			 for(int j=0;j<i;j++)
				 if(arr[j]<arr[i])
					  dp[i]=Math.max(dp[i], dp[j]+1);
		 int ans=-1;
	    for(int i=0;i<n;i++){
	    	ans=Math.max(ans, dp[i]);
	    }
		 System.out.println(ans);
	}
}  

   输出路径:


import java.util.Arrays;
import java.util.Scanner;
 
public class Main {
	static final int max=1005;
	static int dp[]=new int[max];
	static int arr[]=new int[max];
	static int g[]=new int[max];
	public static void print(int k){
		if(k==-1) return;
		print(g[k]);
		System.out.print(arr[k]+" ");
	}
     public static void main(String[] args) {
		 Scanner scan=new Scanner(System.in);
		 int n=scan.nextInt();
		 for(int i=0;i<n;i++)
			 arr[i]=scan.nextInt();
		 for(int i=0;i<n;i++)
		 {
			 dp[i]=1;
			 g[i]=-1;
			 for(int j=0;j<i;j++)
				 if(arr[j]<arr[i])
					  if(dp[i]<dp[j]+1){
						  dp[i]=dp[j]+1;
						  g[i]=j;
					  }
		 }
	    int k=0;
	    for(int i=0;i<n;i++){
	    	if(dp[k]<dp[i]){
	    		k=i;
	    	}
	    }
	    int k1=k;
	    //逆序输出
		for(int i=0,len=dp[k1];i<len;i++){
			System.out.print(arr[k1]+" ");
			k1=g[k1];
		}
		System.out.println();
		
		//正序输出
		print(k);
	}
}  

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

OUC_lkc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值