Cure (数学)

Given an integer nn, we only want to know the sum of 1/k21/k2 where kk from 11 to nn.

Input

There are multiple cases. 
For each test case, there is a single line, containing a single positive integer nn. 
The input file is at most 1M. 

Output

The required sum, rounded to the fifth digits after the decimal point.

Sample Input

1
2
4
8
15

Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044

题意

      给出n,计算1/i*i (1<=i<=n)的和,保留5位小数

思路

    打表,有极限,大于n=1000000时,保留的五位小数就不会再有变化了

代码:
 

#include<iostream>
#include<cmath>
using namespace std;
double sum[1000005];
void init(){
	for(int i=1;i<=1000000;i++){
		sum[i]=1/(i*1.0*i*1.0)+sum[i-1];
	}
}
int main(){
	init();
	string s; 
	while(cin>>s){
	    if(s.length()<=7){
	    	int n=0;
	    	for(int i=0;i<s.length();i++)
	    	   n=n*10+s[i]-'0';
	    	printf("%.5lf\n",sum[n]); 
		}
	    else{
	    	cout<<"1.64493"<<endl;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小鱼爱吃火锅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值