Agri-Net(最小生成树-prim算法模板)

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

 求最小生成树之普里姆算法。该算法从顶点的角度为出发点,临接矩阵时间复杂度O(n2),更适合与解决边的绸密度更高的连通网。 

Prim算法多用于稠密图

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 105
#define Inf 0x3f3f3f3f
int m[maxn][maxn],low[maxn],visited[maxn];
int n;
int prim()
{
	memset(visited,0,sizeof(visited));
	int pos=1;//从某点开始,分别标记和记录该点 
	int result=0;
	visited[1]=1;
	for(int i=1;i<=n;i++)//第一次给low数组赋值
	  if(i!=pos)
	    low[i]=m[pos][i];
	  else 
	    low[i]=0;
	for(int i=1;i<n;i++)//再运行n-1次 
	{
		int minn=Inf;
		for(int j=1;j<=n;j++)
		{
			if(visited[j]==0&&minn>low[j])
			{
				pos=j;
				minn=low[j];
			}
		}
		result+=minn;
		visited[pos]=1;
		for(int j=1;j<=n;j++)//更新权值
		{
			if(visited[j]==0&&low[j]>m[pos][j])
			{
				low[j]=m[pos][j];
			}
		}
	}
    return result;
}
int main()
{
	while(~scanf("%d",&n))
	{
		memset(m,Inf,sizeof(Inf));
		for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
		   scanf("%d",&m[i][j]);
		int ans=prim();
		printf("%d\n",ans);
	}
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

OUC_lkc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值