Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.
What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?
Input
The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 2 31.
Output
For each test case print one line containing the maximum daily amount the government can save.
Sample Input
7 11
0 1 7
0 3 5
1 2 8
1 3 9
1 4 7
2 4 5
3 4 15
3 5 6
4 5 8
4 6 9
5 6 11
0 0
Sample Output
51
题意:节约能源,关闭一些路的路灯,但同时要保证每个居民去是有有路灯的路相连的,求最小的方案。构建最小生成树
思路: 所以边的权值-最小生成树的权值
Kruskal算法多用于稀疏图
代码:
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
int pre[200005];
struct node{
int u,v,d;
}s[200005];
int find(int x)
{
if(pre[x]==x) return x;
else return pre[x]=find(pre[x]);
}
int kruskal(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
{
pre[fx]=fy;
return 1;
}
return 0;
}
int cmp(node a,node b)
{
return a.d<b.d;
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0) break;
for(int i=0;i<n;i++) pre[i]=i;
ll sum=0;
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&s[i].u,&s[i].v,&s[i].d);
sum+=s[i].d;
}
sort(s,s+m,cmp);
ll cnt=0;
for(int i=0;i<m;i++)
{
if(kruskal(s[i].u,s[i].v))
{
cnt+=s[i].d;
}
}
printf("%d\n",sum-cnt);
}
return 0;
}