zoj1093题解 Monkey and Banana

Monkey and Banana

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input Specification

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output Specification

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意:n个砖块,以层叠的方式堆起来,求能堆的最大高度,限制条件是,位于上面的砖块两条边必须小于下面的砖块,给猴子留位置攀登。

 

思路:

这个问题是典型的DAG图的dp问题,由于砖块每种都是无限的,并且可以随意放,可以将每种砖块的三种摆放形式都当成,一种,这种共有3n个砖块了,

该问题跟矩形嵌套问题类似,即求从编号i出发能堆出的最大的高度(不包括i砖块),dp(i) = max(dp(j) + j的高度; j是能放在i上面的砖块编号),算法设计不难,主要是很多细节问题,比较蛋疼,如将开始节点看成地板最大高度为无穷大,结果就为dp(0);

 

代码如下:

#include<iostream>
#include<string>
#include<climits>
using namespace std;

int box[100][3];
int height[100];
int number;
//转换砖块为三种类型
void change(int index,int a,int b,int c)
{
     box[index][0] = a;
     box[index][1] = b;
     box[index][2] = c;
}
//dp
int DP(int j)
{
    int& ans = height[j];
    //搜索过直接返回
    if(ans != -1)return ans;
    
   //搜索每一层
    for(int i = 1; i <= number; i++)
    {
            if(i!=j)
            {
                 if((box[i][0] < box[j][0] && box[i][1] < box[j][1]) || 
                 (box[i][1] < box[j][0] && box[i][0] < box[j][1]))
                 {
                    int  temp = DP(i) + box[i][2];
                    if(temp > ans) ans = temp;       
                 }
            }
    }
    //未更新,说明是最后一层。
    if(ans == -1) ans = 0;
    return ans;
}
int main()
{
    
    int n;
    int Case = 0;
    while(cin >> n && n)
    {
        
        int a,b,c;
        number = 0;
    //地板看成无穷大砖块。
        box[0][0] = box[0][1] = box[0][2] = INT_MAX;
    
        for(int i = 1; i <= n; i++)
        {
                cin >> a >> b >> c;
                change(++number,a,b,c);
                change(++number,b,c,a);
                change(++number,c,a,b);
        }
        
        for(int i = 0; i <= number; i++)
        {
                height[i] = -1;
        }
        cout << "Case " << ++Case << ": maximum height = " << DP(0) << endl;
    }
    return 0;
}



 

 

 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值