11809 - Floating-Point Numbers
题目链接:https://uva.onlinejudge.org/index.PHP?option=com_onlinejudge&Itemid=8&category=226&page=show_problem&problem=2909
Floating-point numbers are represented differently in computers than integers. That is why a 32-bitfloating-point number can represent values in the magnitude of 10^38 while a 32-bit integer can onlyrepresent values as high as 2^32.
Although there are variations in the ways floating-point numbers are stored in Computers, in thisproblem we will assume that floating-point numbers are stored in the following way:
Floating-point numbers have two parts mantissa and exponent. M-bits are allotted for mantissaand E bits are allotted for exponent. There is also one bit that denotes the sign of number (If thisbit is 0 then the number is positive and if it is 1 then the number is negative) and another bit thatdenotes the sign of exponent (If this bit is 0 then exponent is positive otherwise negative). The value ofmantissa and exponent together make the value of the floating-point number. If the value of mantissais m then it maintains the constraints 12 ≤ m < 1. The left most digit of mantissa must always be 1 tomaintain the constraint 12 ≤ m < 1. So this bit is not stored as it is always 1. So the bits in mantissaactually denote the digits at the right side of decimal point of a binary number (Excluding the digitjust to the right of decimal point)
In the figure above we can see a floating-point number where M = 8 and E = 6. The largest valuethis floating-point number can represent is (in binary)
0.111111111(2)×2^111111(2). The decimal equivalentto this number is: 0.998046875 × 2^63 = 9205357638345293824(10). Given the maximum possible valuerepresented by a certain floating point type, you will have to find how many bits are allotted formantissa (M) and how many bits are allotted for exponent (E) in that certain type.
Input
The input file contains around 300 line of input. Each line contains a floating-point number F thatdenotes the maximum value that can be represented by a certain floating-point type. The floating pointnumber is expressed in decimal exponent format. So a number AeB actually denotes the value A×10^B.A line containing ‘0e0’ terminates input. The value of A will satisfy the constraint 0 < A < 10 andwill have exactly 15 digits after the decimal point.
Output
For each line of input produce one line of output. This line contains the value of M and E. You canassume that each of the inputs (except the last one) has a possible and unique solution. You can alsoassume that inputs will be such that the value of M and E will follow the constraints: 9 ≥ M ≥ 0 and30 ≥ E ≥ 1. Also there is no need to assume that (M + E + 2) will be a multiple of 8.
Sample Input
9.205357638345294e18
0e0
Sample Output
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const double min_differ=1e-5;
double M[11][33];
long long E[11][33];
int main()
{
int i,j;
double m,t;
long long e;
char s[123];
for(i=0;i<=9;i++)
{
for(j=0;j<=30;j++)
{
e=(1<<j)-1;//相当于2的b次方-1
m=1-1.0/(1<<(i+1));//1<<(i+1)相当于2的i+1次方
t=log10(m)+e*log10(2);
E[i][j]=t/1;//向下取整
M[i][j]=pow(10,t-E[i][j]);
}
}//打表
while(~scanf("%s",s))
{
if(strcmp(s,"0e0")==0) break;
*(strchr(s,'e'))=' ';//将字符串中的e替换为空格
sscanf(s,"%lf %lld",&m,&e);
for(i=0;i<=9;i++)
{
for(j=1;j<=30;j++)
{
if(e==E[i][j]&&fabs(m-M[i][j])<min_differ)
{
printf("%d %d\n",i,j);
break;
}
}
}
}
return 0;
}
8 6