UVA 12034 Race 动态规划+递推

Disky and Sooma, two of the biggest mega minds of Bangladesh went to a far country. They ate, coded
and wandered around, even in their holidays. They passed several months in this way. But everything
has an end. A holy person, Munsiji came into their life. Munsiji took them to derby (horse racing).
Munsiji enjoyed the race, but as usual Disky and Sooma did their as usual task instead of passing some
romantic moments. They were thinking- in how many ways a race can finish! Who knows, maybe this
is their romance!
In a race there are n horses. You have to output the number of ways the race can finish. Note that,
more than one horse may get the same position. For example, 2 horses can finish in 3 ways.
1. Both first
2. horse1 first and horse2 second
3. horse2 first and horse1 second
Input
Input starts with an integer T (≤ 1000), denoting the number of test cases. Each case starts with a
line containing an integer n (1 ≤ n ≤ 1000).
Output
For each case, print the case number and the number of ways the race can finish. The result can be
very large, print the result modulo 10056.
Sample Input
3
1
2
3
Sample Output
Case 1: 1
Case 2: 3

Case 3: 13

dp[i][j]表示第i匹马分j次到达的方法数

递推公式为dp[i][j]=(dp[i][j-1]+dp[i-1][j-1])*j;

dp[i][j-1]为第i匹马与前面的马一起到达,dp[i-1][j-1]代表第i匹马单独到达,一共有j种情况

还有就是取模公式

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mod=10056;
int dp[1100][1100];
int ans[1100];
void Init()
{
    int i,j;
    memset(dp,0,sizeof(dp));
    memset(ans,0,sizeof(ans));
    dp[0][0]=1;
    int sum;
    for(i=1;i<=1000;i++)
    {
        sum=0;
        for(j=1;j<=i;j++)
        {
            dp[i][j]=((dp[i-1][j]+dp[i-1][j-1])%mod*j%mod)%mod;
            sum=(sum%mod+dp[i][j]%mod)%mod;
        }
        ans[i]=sum;
    }
}
int main()
{
    Init();
    int t;
    scanf("%d",&t);
    int count=0;
    while(t--)
    {
        count++;
        int n;
        scanf("%d",&n);
        printf("Case %d: %d\n",count,ans[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值