HDU 5268 ZYB loves Score (BestCoder Round#44)

题目链接:ZYB loves Score


题面:

ZYB loves Score

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 395    Accepted Submission(s): 232


Problem Description
One day,ZYB participated in the BestCoder Contest 

There are four problems. Their scores are 1000,1500,2000,2500 

According to the rules of BestCoder,If you solve one problem at  x  minutes,
You will get (250-x)/250 100 %  of the original scores.

Obviously the final score must be an integer,becasue the original scores are multiple of 250

And if you make  x  wrong submissions,the score of this problem you get will be reduced by 50

For example, if you solved the first problem in 5 minutes and you make one wrong submisson, the score of this problem is 980-50=930 

To prevent very low scores,the lowest score of one problem is  40%  of its original score
 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases. Each test case contains four lines

For i-th line of each test case there are two integers  A , B  which means you solved the i-th problem in A minutes and you have made B wrong submissons.

0A105 0B100
 

Output
For each case, the output should occupies exactly one line. The output format is Case #x: ans, here x is the data number begins at 1.
 

Sample Input
  
  
2 4 0 12 0 20 0 103 0 17 1 29 0 57 0 84 0
 

Sample Output
  
  
Case #1: 5722 Case #2: 5412
 

Source
 


解题:套下公式即可,注意分数不能低于40%。


代码:

#include <iostream>
#include <cmath> 
#define e  2.718281828459
using namespace std;
int max(double a,int b)
{
	if(a>b)return (int)a;
	else return b;
}
int main()
{
	int t,total,timee,wrong;
	cin>>t;
	for(int i=1;i<=t;i++)
	{
		total=0;
		for(int j=1000;j<=2500;j+=500)
		{
			cin>>timee>>wrong;
			total+=max((250.0-timee)/250*j-wrong*50,j*2/5);
		}
		cout<<"Case #"<<i<<": "<<total<<endl;
	}
   return 0; 
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值