7-124 Wifi密码(简洁AC)

下面是微博上流传的一张照片:“各位亲爱的同学们,鉴于大家有时需要使用 wifi,又怕耽误亲们的学习,现将 wifi 密码设置为下列数学题答案:A-1;B-2;C-3;D-4;请同学们自己作答,每两日一换。谢谢合作!!~”—— 老师们为了促进学生学习也是拼了…… 本题就要求你写程序把一系列题目的答案按照卷子上给出的对应关系翻译成 wifi 的密码。这里简单假设每道选择题都有 4 个选项,有且只有 1 个正确答案。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行按照 编号-答案 的格式给出一道题的 4 个选项,T 表示正确选项,F 表示错误选项。选项间用空格分隔。

输出格式:

在一行中输出 wifi 密码。

输入样例:

8
A-T B-F C-F D-F
C-T B-F A-F D-F
A-F D-F C-F B-T
B-T A-F C-F D-F
B-F D-T A-F C-F
A-T C-F B-F D-F
D-T B-F C-F A-F
C-T A-F B-F D-F

输出样例:

13224143

 简洁AC

#include<iostream>
using namespace std;
int main()
{
    int num;
    char flag[4];
    cin >> num;
    while (num--)
    {
        for(int z=0;z<4;z++)
        {
            cin >> flag;
            if(flag[2]=='T') cout << flag[0]-64;
        }
    }
    return 0;
}

D wpa_supplicant v2.10-devel-11 D Global control interface '@android:wpa_wlan0' D Using Android control socket 'wpa_wlan0' D Initing hidl control I Processing hidl events on FD 5 I Successfully initialized wpa_supplicant E check_wifi_chip_type_string : RTL8733BS: Success I Use /vendor/etc/wifi/wpa_supplicant_rtk.conf, read ok. D Override interface parameter: ctrl_interface ('(null)' -> '/data/vendor/wifi/wpa/sockets') D Initializing interface 'wlan0' conf '/data/vendor/wifi/wpa/wpa_supplicant.conf' driver 'nl80211' ctrl_interface '/data/vendor/wifi/wpa/sockets' bridge 'N/A' D Configuration file '/data/vendor/wifi/wpa/wpa_supplicant.conf' -> '/data/vendor/wifi/wpa/wpa_supplicant.conf' D Reading configuration file '/data/vendor/wifi/wpa/wpa_supplicant.conf' D update_config=1 D eapol_version=1 D ap_scan=1 D fast_reauth=1 D pmf=1 D p2p_add_cli_chan=1 D oce=1 D wowlan_disconnect_on_deinit=1 D Reading configuration file '/vendor/etc/wifi/wpa_supplicant_rtk.conf' D p2p_disabled=1 D wowlan_triggers='any' D nl80211: Supported cipher 00-0f-ac:1 D nl80211: Supported cipher 00-0f-ac:5 D nl80211: Supported cipher 00-0f-ac:2 D nl80211: Supported cipher 00-0f-ac:4 D nl80211: Supported cipher 00-0f-ac:6 D nl80211: Supported cipher 00-0f-ac:8 D nl80211: Supported cipher 00-0f-ac:9 D nl80211: Supported cipher 00-0f-ac:10 D nl80211: Supported cipher 00-0f-ac:11 D nl80211: Supported cipher 00-0f-ac:12 D nl80211: Supported cipher 00-0f-ac:13 D nl80211: Supported vendor command: vendor_id=0x1a11 subcmd=4106 D nl80211: Supported vendor command: vendor_id=0x1a11 su
最新发布
04-03
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值