1036 Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​−gradeM​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.


Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

题目大意

找出女生中最高得分的那位A,与男生中得分最低的那位B

依次输出 :

A.name A.score , 不存在 输出 Absent

B.name B.score , 不存在 输出 Absent

abs(A.score,B.score)  A或B有一个不存在,输出 NA


思路

超级简单的一道题...


C/C++ 

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int N,score,boy=2022,girl=-2021;
    string name,id,boyName,boyId,girlName,girlId,sex;
    cin >> N;
    while (N--){
        cin >> name >> sex >> id >> score;
        if(sex=="M" && score<boy){
            boy = score;
            boyName = name;
            boyId = id;
        }
        if(sex=="F" && score>girl){
            girl = score;
            girlName = name;
            girlId = id;
        }
    }
    if(girl!=-2021) cout << girlName << " " << girlId << endl;
    else cout << "Absent" << endl;
    if(boy!=2022) cout << boyName << " " << boyId << endl;
    else cout << "Absent" << endl;
    if(girl!=-2021 && boy!=2022) cout << abs(boy-girl) << endl;
    else cout << "NA" << endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值