PAT 1039 Course List for Student [map] [vector] [hash]

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

----------------------------------这是题目和解题的分割线----------------------------------

使用map和string会超时,所以还是用hash表转换一下名字吧。

如果用二维数组来存储学生和所选课程,最后一组数据会内存超限,所以用vector可变数组。

#include<cstdio>
#include<vector>
#include<algorithm>

//学生姓名前三为字母最后一位是数字,共有maxN种可能性 
const int maxN = 26*26*26*10;

using namespace std;

//maxN比较大,要全局变量 
vector<int> stu[maxN];

//hash转换 
int charToId(char s[])
{
	int i,x = 0;
	//前三个是字母 26进制转换为十进制 
	for(i=0;i<3;i++)
		x = x*26 + s[i] - 'A';
	//十进制 
	x = x*10 + s[i] - '0';
	return x;
}

int main()
{
	int n,k,i;
	scanf("%d%d",&n,&k);
	while(k--)
	{
		int cNum,sNum,name;
		scanf("%d%d",&cNum,&sNum);
		for(i=0;i<sNum;i++)
		{
			char s[5];
			scanf("%s",s);
			name = charToId(s);
			//push_back函数将课程加入该学生的数组里 
			stu[name].push_back(cNum);
		}
	}
	for(i=0;i<n;i++)
	{
		char q[5];
		scanf("%s",q);
		int sname = charToId(q);
		//vector很方便自带size无需统计 
		printf("%s %d",q,stu[sname].size());
		if(stu[sname].size())
		{
			//别忘了课程输出得递增顺序!
			//vector排序不能stu[sname],stu[sname]+stu[sname].size(),需用begin和end 
			sort(stu[sname].begin(),stu[sname].end());
			for(int j=0;j<stu[sname].size();j++)
				printf(" %d",stu[sname][j]);
		}
		printf("\n");
	}
	return 0; 
}

诶是不是改时间限制了,现在用map和vector组合也不会超时。那就也放上来吧。

#include<cstdio>
#include<algorithm>
#include<map>
#include<vector>
#include<iostream>

using namespace std;

int main()
{
	map<string,vector<int> > mp;
	int i,j,n,k;
	cin>>n>>k;
	for(i=0;i<k;i++)
	{
		int index,num;
		string stu;
		cin>>index>>num;
		for(j=0;j<num;j++)
		{
			cin>>stu;
			mp[stu].push_back(index);
		}		
	}
	for(i=0;i<n;i++)
	{
		string q;
		cin>>q;
		sort(mp[q].begin(),mp[q].end());
		cout<<q<<" "<<mp[q].size();
		for(auto it=mp[q].begin();it!=mp[q].end();it++)
			cout<<" "<<*it;
		cout<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值