1043 Is It a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.


Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题目大意

给你一串数组,判断这是否是对⼀棵⼆叉搜索树或其镜像翻转后,进⾏前序遍历的结果
是的话输出 YES + 该树的后续遍历
否则 NO

思路

分类讨论是否为镜像翻转


C/C++ 

#include<bits/stdc++.h>
using namespace std;
vector<int> tree1,tree2;
int N,num;
bool flag = true; // 判断有无镜像翻转
void create(int head,int tail);
int main()
{
    cin >> N;
    for(int z=0;z<N;z++){
        cin >> num;
        tree1.push_back(num);
    }
    create(0,N-1);
    if(tree2.size()!=tree1.size()){
        tree2.clear();
        flag = false;
        create(0,N-1);
    }

    if(tree2.size()!=tree1.size()) puts("NO");
    else
    {
        cout << "YES" << endl << tree2[0];
        for(int z=1;z<N;z++) cout << " " << tree2[z];
    }
    return 0;
}
void create(int head,int tail)
{
    if(head>tail) return;
    int left=head+1,right=tail;
    if(flag){
        while (left<=tail && tree1[head]>tree1[left]) left++;
        while (right>head && tree1[head]<=tree1[right]) right--;
    }else{
        while (left<=tail && tree1[head]<=tree1[left]) left++;
        while (right>head && tree1[head]>tree1[right]) right--;
    }
    if(left-right>1) return;
    create(head+1,left-1);
    create(right+1,tail);
    tree2.push_back(tree1[head]);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值