1049 Counting Ones

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤230).

Output Specification:

For each test case, print the number of 1's in one line.


Sample Input:

12

Sample Output:

5

题目大意

求1~N出现了几个1

1~11算出现4个1,即 1,10,11


思路

数学题,可以直接推算出每个位数1出现多少次


C/C++ 

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int main()
{
    LL N,op=1,result=0;
    cin >> N;
    while (N>=op){
        LL key = N/op%10;
        LL left =  N/(op*10);
        LL right = N%op;
        if(key==0) result += left*op;
        else if(key==1) result += left*op+right+1;
        else result += (left+1)*op;
        op*=10;
    }
    cout << result << endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值