1049 Counting Ones(30 分)

1049 Counting Ones(30 分)
The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:
Each input file contains one test case which gives the positive N (≤2
​30
​​ ).

Output Specification:
For each test case, print the number of 1’s in one line.

Sample Input:
12
Sample Output:
5

解题思路:
数学模拟,不可以用1-N枚举的方式,会超时。通过每一位数字找规律。
设置left,now,right,表示当前为左边的数,当前位的数字,当前位右边的数,a表示当前的位数,如个十百分别用1,10,100表示,则1的总个数可以根据
当now== ans+=left*a;
当now==1 ans+=left*a+right+1;
当now>=2 ans+=(left+1)*a;
证明参见算法笔记。

#include<cstdio>
int main(){
    int a=1,ans=0,n;
    int left,right,now;
    scanf("%d",&n);
    while(n/a!=0){
        left=n/(a*10);
        right=n%a;
        now=n/a%10;
        if(now==0)  ans+=left*a;
        else if(now==1) ans+=left*a+right+1;
        else ans+=(left+1)*a;
        a*=10;
    }
    printf("%d\n",ans);

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值