1057 Stack

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤105). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.


Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题目大意

标准栈操作,只不过多了 “查询栈里边所有元素的中位数”;


思路

额外设置一个动态数组(vector)存储当前所有元素的排序


C/C++ (自己实现了二分查找)

//#include<bits/stdc++.h>
#include<iostream>
#include<vector>
#include<stack>
using namespace std;
int findMid(const vector<int>& box,int num){
    int head=0,tail=box.size()-1;
    while (head<=tail){
        int mid = (head+tail)/2;
        if(box[mid]==num) return mid;
        else if(box[mid]<num) head = mid+1;
        else tail = mid-1;
    }
    return -1;
}
int findMin(const vector<int>& box,int num){
    int head=0,tail=box.size()-1;
    while (head<=tail){
        int mid = (head+tail)/2;
        if(box[mid]<num) head = mid+1;
        else tail = mid-1;
    }
    return head;
}
    int main()
{
    vector<int> key;
    vector<int> ::iterator flag;
    stack<int> box;
    string s;
    int N,num;
    cin >> N;
    while (N--){
        cin >> s;
        if(s=="Push"){
            cin >> num;
            int op = findMin(key,num);
            key.insert(key.begin()+op,num);
            box.push(num);
        }
        else if(s=="Pop"){
            if(box.empty()) puts("Invalid");
            else
            {
                num = box.top();
                int op = findMid(key,num);
                key.erase(key.begin()+op);
                box.pop();
                cout << num << endl;
            }
        }
        else
        {
            if(box.empty()) puts("Invalid");
            else if(box.size()%2==0) cout << key[(box.size()-1)/2] << endl;
            else cout << key[(box.size())/2] << endl;
        }
    }

    return 0;
}


C/C++ (内置函数二分查找)


#include<bits/stdc++.h>
using namespace std;
int main()
{
    vector<int> key;
    vector<int> ::iterator flag;
    stack<int> box;
    string s;
    int N,num;
    cin >> N;
    while (N--){
        cin >> s;
        if(s=="Push"){
            cin >> num;
            flag = lower_bound(key.begin(), key.end(),num);
            key.insert(flag,num);
            box.push(num);
        }
        else if(s=="Pop"){
            if(box.empty()) puts("Invalid");
            else
            {
                num = box.top();
                flag = lower_bound(key.begin(),key.end(),num);
                key.erase(flag);
                box.pop();
                cout << num << endl;
            }
        }
        else
        {
            if(box.empty()) puts("Invalid");
            else if(box.size()%2==0) cout << key[(box.size()-1)/2] << endl;
            else cout << key[(box.size())/2] << endl;
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值