POJ 3461

1 篇文章 0 订阅

Oulipo

Time Limit: 1000MS
Memory Limit: 65536K

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

思路

  • 裸KMP
  • 一次匹配完成之后要回溯

代码

#include<iostream>
#include<string.h>
using namespace std;

char T[100000];//模式串 子串
char S[10000000];//主串
int slen;
int tlen;
int pos=1;//开始匹配的位置
int next1[100000];
int ans=0;
void getNext();
void KMP(){
    int i=pos;
    int j=1;

    while(i<=slen&&j<=tlen){
        if(j==0||S[i]==T[j]){
            i++;
            j++;

        }else{
            j=next1[j];
        }
        if(j>tlen){//子串一趟匹配完成之后 回溯
            ans++;
            j=next1[j];
        }
    }


}
int main(){
    //freopen("in.txt","r",stdin);
    int n;
    cin>>n;
    while(n--){
        memset(S,'0',sizeof(S));
        memset(T,'0',sizeof(T));
        int t;
        for(t=0;t<100000;t++){
            next1[t]=0;
        }
        ans=0;
        cin>>&T[1]; //从1开始存
        cin>>&S[1];

        tlen=strlen(T)-1;//字符串的实际长度 因为是从1开始存的
        slen=strlen(S)-1;
        getNext();
        KMP();
        cout<<ans;
        cout<<endl;

    }
//  fclose(stdin);

    //freopen("CON","r",stdin);
    //system("pause");
    return 0;
}
/*整个模式串既是主串又是模式串*/
void getNext(){

    int i=1; //主串下标
    int j=0; //子串下标
    next1[1]=0;
    while(i<=tlen){//存到最后一个字符的下一个
        if(j==0||T[i]==T[j]){
            i++;
            j++;
            next1[i]=j;
        }else{
            j=next1[j];//失配后回溯
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值