poj 3461 Oulipo

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output

1
3
0
题目意思就是说,输入两个字符串,在第二个字符串里面可以找到几个第一个字符串并输出。这道题既可以用kmp来做也可以用hash来做。
不得不说hash真的是一个强大的工具,优雅的暴力真的可以解决好多,,,,这是一个dalao给我讲解的(不仅万分感谢,还要膜拜一波)

#include<cstdio>
#include<iostream>
#include<cstring>
#define N 1000005
using namespace std;
typedef unsigned long long ull;
char s1[N];
char s2[N];
ull hs[N];
ull base = 131;
ull b[N];
ull geths(int l,int r) {   //用来得到 某一段字符串的hash值
	return hs[r]-hs[l-1]*b[r-l+1]; // 段指的就是 l - r  的长度,b[r-l+1]代表有几个base(这需要公式推导一下) 
}


int main() {
	b[0]=1;
	for(int i=1; i<1000001; i++) {
		b[i] = b[i-1]*base;   
	}
	int t;
	scanf("%d",&t);
	while(t--) {
		scanf("%s %s",s1+1,s2+1);
		
		memset(hs,0,sizeof(hs));
		
		int k1=strlen(s1+1);
		int k2=strlen(s2+1);
		
		ull ans = 0;
		for(int i=1; i<=k1; i++) {
			ans = ans*base+(ull)s1[i];
		}
		for(int i=1; i<=k2; i++) {
			hs[i] = hs[i-1]*base+(ull)s2[i]; // 用来算出字符串2每一个hash值
		}									// 就像是 abcde 的hash 值, 这个数组存的就是 a ab abc abcd  abcde 这几个的hash值
		int sum = 0;						// 我想要得到 某一段的hash值,只需要拿前一段减去后一段  
		for(int i=1; i+k1-1<=k2; i++) {
			if(ans==geths(i,i+k1-1)) 	// 得到某一段的hash值 哪一段?
				sum++;					// cde  abcde  匹配比较
		}								// 我想要知道 第二个字符串的从第3位到第五位的hash值
		printf("%d\n",sum);				// 就是geths(i,i+len1-1); len1表示字符串1的长度 
										// i 代表当前在第几位 加上字符串1的长度就是我要的那段字符串的hash值
	} 
	return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值