【洛谷3110】【USACO14DEC】驮运Piggy Back

题目描述

Bessie and her sister Elsie graze in different fields during the day, and in the evening they both want to walk back to the barn to rest. Being clever bovines, they come up with a plan to minimize the total amount of energy they both spend while walking.

Bessie spends B units of energy when walking from a field to an adjacent field, and Elsie spends E units of energy when she walks to an adjacent field. However, if Bessie and Elsie are together in the same field, Bessie can carry Elsie on her shoulders and both can move to an adjacent field while spending only P units of energy (where P might be considerably less than B+E, the amount Bessie and Elsie would have spent individually walking to the adjacent field). If P is very small, the most energy-efficient solution may involve Bessie and Elsie traveling to a common meeting field, then traveling together piggyback for the rest of the journey to the barn. Of course, if P is large, it may still make the most sense for Bessie and Elsie to travel

separately. On a side note, Bessie and Elsie are both unhappy with the term "piggyback", as they don't see why the pigs on the farm should deserve all the credit for this remarkable form of

transportation.

Given B, E, and P, as well as the layout of the farm, please compute the minimum amount of energy required for Bessie and Elsie to reach the barn.

Bessie 和 Elsie在不同的区域放牧,他们希望花费最小的能量返回谷仓。从一个区域走到一个相连区域,Bessie要花费B单位的能量,Elsie要花费E单位的能量。如果某次他们两走到同一个区域,Bessie 可以背着 Elsie走路,花费P单位的能量走到另外一个相连的区域,满足P<B+E。相遇后,他们可以一直背着走,也可以独立分开。

输入输出格式

输入格式:

INPUT: (file piggyback.in)

The first line of input contains the positive integers B, E, P, N, and M. All of these are at most 40,000. B, E, and P are described above. N is the number of fields in the farm (numbered 1..N, where N >= 3), and M is the number of connections between fields. Bessie and Elsie start in fields 1 and 2, respectively. The barn resides in field N.

The next M lines in the input each describe a connection between a pair of different fields, specified by the integer indices of the two fields. Connections are bi-directional. It is always possible to travel from field 1 to field N, and field 2 to field N, along a series of such connections.

输出格式:

OUTPUT: (file piggyback.out)

A single integer specifying the minimum amount of energy Bessie and

Elsie collectively need to spend to reach the barn. In the example

shown here, Bessie travels from 1 to 4 and Elsie travels from 2 to 3

to 4. Then, they travel together from 4 to 7 to 8.

输入输出样例

输入样例#1:
4 4 5 8 8 
1 4 
2 3 
3 4 
4 7 
2 5 
5 6 
6 8 
7 8 
输出样例#1:
22 
题解
 先考虑一下,如果两人相遇后再分开会不会使结果更优,设第一个人代价是a,第二个人的代价是b(a>b),一起走的代价
为p,现在有两条道路x,y.分开走的代价(x<y)ax+by,一起走的待代价是p*x,显然ax+by>px(将y边成x,左边变小但仍大于右边)。x>y
的情况同理,所以一定是合起来走更优。这样就枚举中间合并的点就行了。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=100010;
int pre[maxn],last[maxn],other[maxn],num,w[maxn];
int db[maxn],dp[maxn],de[maxn],b,e,p,n,m;;
bool vis[maxn];
void add(int x,int y,int z){
    num++;
    pre[num]=last[x];
    last[x]=num;
    other[num]=y;
    w[num]=z;
}
void spfa(int x,int *dis){
    queue<int>q;
    //memset(dis,127/3,sizeof(dis));memset好像不能用 
    for(int i=1;i<=n;i++)
    dis[i]=10000000;
    memset(vis,0,sizeof(vis));
    q.push(x);
    vis[x]=1;
    dis[x]=0;
    while(!q.empty()){
        int t=q.front();
        q.pop();
        vis[t]=0;
        for(int i=last[t];i;i=pre[i]){
            int v=other[i];
        //    cout<<dis[v]<<" "<<dis[t]<<" "<<w[i]<<endl; 
            if(dis[v]>dis[t]+w[i]){
                dis[v]=dis[t]+w[i];
                if(!vis[v]){
                    q.push(v);
                    vis[v]=1;
                }
            }
        }
    }
}
int main(){
    int x,y,z;
    scanf("%d%d%d%d%d",&b,&e,&p,&n,&m);
    for(int i=1;i<=m;i++){
        scanf("%d%d",&x,&y);
        add(x,y,1);
        add(y,x,1);
    }
    spfa(1,db);
    spfa(2,de);
    spfa(n,dp);
    int ans=2147483647;
    for(int i=1;i<=n;i++)
    ans=min(ans,dp[i]*p+db[i]*b+de[i]*e);
    
    printf("%d\n",ans);
//    system("pause");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值