Sicily 1231. The Embarrassed Cryptography

  1. The Embarrassed Cryptography
    Constraints
    Time Limit: 2 secs, Memory Limit: 32 MB
    Description
    The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
    What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss’ key.

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
Output
For each number K, if one of its factors are strictly less than the required L, your program should output “BAD p”, where p is the smallest factor in K. Otherwise, it should output “GOOD”. Cases should be separated by a line-break.
Sample Input
143 10
143 20
667 20
667 30
2573 30
2573 40
0 0
Sample Output
GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

这道题主要考察对一个大整数的质数分解,由于质数的范围我们是知道的,所以可以在这个范围中打印出来素数表
在这里插入图片描述
接下来是大数取余的过程,这里举一个例子12%7
先用1%7,结果为1,然后110=10;
接下来10+2=12,12%7=5就是最终答案,其实就是从最高位开始取模,然后
10加上下一位继续取模
在这里插入图片描述
接下来就是检测被分解出来的质数是否小于题目中所给出来的数字
在这里插入图片描述

#include<iostream>
#include<vector>
#include<cstring>
#include<cmath>
using namespace std;
vector<int>prime;
bool isprime(int n){
	for(int i=2;i<sqrt(n);i++){
		if(n%i==0){
			return false;
		}
	}
	return true;
}
void find(){
	for(int i=2;i<1000001;i++){
		if(isprime(i)){
			prime.push_back(i);
		}
	}
}
bool mod(vector<int>integer,int n){
	int len=integer.size();
	int m;
	m=integer[0];
	for(int i=0;i<len-1;i++){
		m=(m%n)*10+integer[i+1];
	}
	m=m%n;
	return m==0;
}
int main(){
	find();
	string s;
	int p;
	int length=prime.size();
	while(cin>>s>>p){
		if(s=="0"&&p==0){
			break;
		}
		int len=s.size();
		vector<int>v;
		for(int i=0;i<len;i++){
			v.push_back(s[i]-'0');
		}
		bool flag=true;
		for(int i=0;i<length;i++){
			if(mod(v,prime[i])){
				//cout<<prime[i];
				if(prime[i]<p){
					
					cout<<"BAD "<<prime[i]<<endl;
					flag=false;
					break;
				}
			}
		}
		if(flag){
			cout<<"GOOD"<<endl;
		}
		mod(v,11);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值