HDU-4277 USACO ORZ

Time Limit: 1500MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 
I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N fence segments and must arrange them into a triangular pasture. Ms. Hei must use all the rails to create three sides of non-zero length. Calculating the number of different kinds of pastures, she can build that enclosed with all fence segments. 
Two pastures look different if at least one side of both pastures has different lengths, and each pasture should not be degeneration. 
 

Input

The first line is an integer T(T<=15) indicating the number of test cases. 
The first line of each test case contains an integer N. (1 <= N <= 15) 
The next line contains N integers li indicating the length of each fence segment. (1 <= li <= 10000) 
 

Output

For each test case, output one integer indicating the number of different pastures. 
 

Sample Input

    
    
1 3 2 3 4
 

Sample Output

    
    
1

 

题目:给定一些一定长度的线段,要求全部利用这些线段能拼成多少种三角形(如果两个三角形至少有一条边长度不等那么二者视为两种)
思路:DFS,对于所有满足情况的三角形加入set中,这样就去重了,最后set的大小就是答案

代码:

#include<iostream>
#include<set>
#include<map>
#include<cstring>
#include<algorithm>
using namespace std;
int a[100],n,m,b[100];
set< pair<int ,int> >s;
void dfs(int x)
{
if(x==m)
{
if(b[0]<=b[1]&&b[1]<=b[2]&&b[0]+b[1]>b[2])
{
s.insert(make_pair(b[0],b[1]));
// cout<<b[0]<<b[1]<<b[2]<<endl;
}
return ;
}
for(int i=0;i<3;i++)
{
b[i]+=a[x];
dfs(x+1);
b[i]-=a[x];
}

}
int main()
{


cin>>n;

while(n--)
{
s.clear();
cin>>m;
for(int i=0;i<m;i++)
cin>>a[i];
dfs(0);

cout<<s.size()<<endl;
}

return 0;
 } 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值