POJ 1151 Wormholes spfa+反向建边+负环判断+链式前向星

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 49962 Accepted: 18421

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

思路:

正常的路是双向走通的,虫洞花费的时间是负的,输入为正整数,然前加负号建边,同时也是单向的。假如有负环,说明可以自己遇到自己,否则不行。

代码:

#include<iostream>
#include<string>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
using namespace std;
const int maxn=505;
const int maxm=5405;
const int INF=0x3f3f3f3f;
struct edgenode {
    int to,w,next;
}edges[maxm];
bool vis[maxn];
int dist[maxn],du[maxn],head[maxn];
int n,cnt;
bool spfa() {
    memset(dist,INF,sizeof(dist));
    memset(vis,false,sizeof(vis));
    memset(du,0,sizeof(du));
    dist[1]=0;vis[1]=true;
    queue<int> q;
    q.push(1);
    while(!q.empty()) {
        int now=q.front();q.pop();
        ++du[now];
        if(du[now]>n) return false;
        vis[now]=false;
        for(int i=head[now];~i;i=edges[i].next) {
            if(dist[edges[i].to]>dist[now]+edges[i].w) {
                dist[edges[i].to]=dist[now]+edges[i].w;
                if(!vis[edges[i].to]) {
                    vis[edges[i].to]=true;
                    q.push(edges[i].to);
                }
            }
        }
    }
    return true;
}
void addedge(int u, int v, int w) {
    edges[cnt].to=v;
    edges[cnt].w=w;
    edges[cnt].next=head[u];
    head[u]=cnt++;
}
void init() {
    for(int i=0;i<maxn;++i) head[i]=-1;
    for(int i=0;i<maxm;++i) edges[i].next=-1;
    cnt=0;
}
int main() {
    int t;
    scanf("%d",&t);
    while(t--) {
        int m,w,s,e,t;
        init();
        scanf("%d%d%d",&n,&m,&w);
        for(int i=0;i<m;++i) {
            scanf("%d%d%d",&s,&e,&t);
            addedge(s,e,t);addedge(e,s,t);
        }
        for(int i=0;i<w;++i) {
            scanf("%d%d%d",&s,&e,&t);
            addedge(s,e,-t);
        }
        if(!spfa()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


转载于:https://www.cnblogs.com/lemonbiscuit/p/7775977.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值