POJ 3259 Wormholes spfa

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.




思路  把虫洞的权值设为负值,判断是否存在负圈 


#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int M=6000;
const int N=510;
struct sg
{
    int l,r;
    int cost;
    int next;
}ev[M];
int t;
int n,m,w;
int dis[N];
int vis[N];
int cmp;
int head[M];
int cnt[M];
//前向星优化 http://www.layz.net/LAOJ/suanfa/s9-4.html
void fuzhi(int a,int b,int c)
{
    ev[cmp].l=a;
    ev[cmp].r=b;//记录后继节点 相当于链表中的创建一个节点,并使得数据域先记录
    ev[cmp].cost=c;
    ev[cmp].next=head[a];//记录顶点节点的某一个边表节点的下标,
    //相当于在链表中吧该边表节点的next指针先指向他的后继边表节点
    head[a]=cmp++;
}
bool spfa(int st)
{
    queue<int>q;
    for(int i=0;i<=n;i++)
    {
        dis[i]=inf;
    }
    memset(vis,0,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    dis[st]=0;
    q.push(st);
    vis[st]=1;
    cnt[st]++;
    while(q.size())
    {
        int now=q.front();
        q.pop();
        vis[now]=0;
        if(cnt[now]>=n)
            return false;
        for(int i=head[now];i!=-1;i=ev[i].next)
        {
            int nex=ev[i].r;
            if(dis[nex]>dis[now]+ev[i].cost)
            {
                dis[nex]=dis[now]+ev[i].cost;
                if(!vis[nex])
                {
                    vis[nex]=1;
                    cnt[nex]++;
                    if(!q.empty()&&dis[nex]<dis[q.front()])
                    {
                        q.push(nex);
                    }
                    else
                    {
                        q.push(nex);
                    }
                }
            }
        }
    }
    return true;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        cmp=0;
        int a,b,c;
        memset(head,-1,sizeof(head));
        scanf("%d%d%d",&n,&m,&w);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            fuzhi(a,b,c);
            fuzhi(b,a,c);
        }
        for(int i=0;i<w;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            fuzhi(a,b,0-c);
        }
        if(spfa(1))
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值