HDU1042---N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 77404    Accepted Submission(s): 22617


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
 
  
1 2 3
 

Sample Output
 
  
1 2 6
 
Java大数水一发:
import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner s = new Scanner(System.in);
		while(s.hasNext()) {
			BigInteger bi = new BigInteger("1");
			int t = s.nextInt();
			for(int i=1;i<=t;i++) {
				String ss = i + "";
				BigInteger t1 = new BigInteger(ss);
				bi=bi.multiply(t1);
			}
			System.out.println(bi);
		}	
		s.close();
	}
}


转载于:https://www.cnblogs.com/lemonbiscuit/p/7776046.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值