S - N! HDU - 1042(大数运算)

S - N!

HDU - 1042

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3

Sample Output

1
2
6
#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=111;
const int mmax=111111;
const int MOD = 1e5+ 7;
int num[mmax];   //用数组保存每一位上得到的结果
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        int mod=0;   //保留进位
        int k=1;
        num[0]=1;
        for(int i=n;i>=1;i--){
            for(int j=0;j<k;j++){
             mod=num[j]*i+mod;
              num[j]=mod%10;
              mod=mod/10;
            }
            while(mod){  //处理最高位计算完后的进位
                num[k++]=mod%10;
              mod/=10;
            }
        }
        for(int i=k-1;i>=0;i--)
           printf("%d",num[i]);
        printf("\n");
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值