WERTYU acm

题目描述
A common typing error is to place the hands on the keyboard one row to the right of the correct position. So “Q” is typed as “W” and “J” is typed as “K” and so on. You are to decode a message typed in this manner.
键盘说明
Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input. You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output.
输入
输出
样例输入
O S, GOMR YPFSU/
样例输出
I AM FINE TODAY.
题解
拿到题,首先就应该想到如何去取某字符右边的字符。这里用的方法就是按从左到右的顺序存入一维字符数组中。然后每读到一个转化一个。
这里的(c=getchar())!=EOF相当于scanf(“%c”,&c)!=EOF.
这里值得注意的是,对于’\’,在C语言中它是转义字符,所以我们这里要存为’\’。
源码

#include "cstdio"
#include "cstring"
#include "algorithm"
#include "iostream"
#include "cmath"
using namespace std;
int main()
{
    char a[]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
    int c,i;
    while(EOF!=(c=getchar()))
    {
        for(i=0;a[i]&&a[i]!=c;i++);
        if(a[i]){
            putchar(a[i-1]);
        }else{
            putchar(c);
        }
    }
    return 0;
}

练习网址:http://acm.hnust.cn/JudgeOnline/problem.php?id=1248

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值